Hackin9
(c) SANS Internet Storm Center. https://isc.sans.edu Creative Commons Attribution-Noncommercial 3.0 United States License.
 
GNU Bash CVE-2014-6271 Remote Code Execution Vulnerability
 
Mozilla Network Security Services CVE-2014-1568 Security Bypass Vulnerability
 
Mac OS X Mavericks is also a *nix, and also vulnerable to the Bash bug.
Sean Gallagher

A security vulnerability in the GNU Bourne Again Shell (Bash), the command-line shell used in many Linux and Unix operating systems, could leave systems running those operating systems open to exploitation by specially crafted attacks. “This issue is especially dangerous as there are many possible ways Bash can be called by an application,” a Red Hat security advisory warned.

The bug, discovered by Stephane Schazelas, is related to how Bash processes environmental variables passed by the operating system or by a program calling a Bash-based script. If Bash has been configured as the default system shell, it can be used by network–based attackers against servers and other Unix and Linux devices via Web requests, secure shell, telnet sessions, or other programs that use Bash to execute scripts.

Because of its wide distribution, the vulnerability could be as wide-ranging as the Heartbleed bug, though it may not be nearly as dangerous. The vulnerability affects versions 1.14 through 4.3 of GNU Bash. Patches have been issued by many of the major Linux distribution vendors for affected versions, including:

Read 7 remaining paragraphs | Comments

 
phpMyAdmin Micro History Feature Cross Site Scripting Vulnerability
 

Over the past years, we became used to Microsoft Patches, the important, critical ones that would render your system fully vulnerable if you didn't apply them. We probably became so used that sometime we forget that our Linux servers also need patches.

Today I've learned about a critical Bash patch, that addresses the CVE-2014-6271. According the advisory:

"A flaw was found in the way Bash evaluated certain specially crafted environment variables. An attacker could use this flaw to override or bypass environment restrictions to execute shell commands. Certain services and applications allow remote unauthenticated attackers to provide environment variables, allowing them to exploit this issue."

The patches are already ready for most of the Linux distros, like RedHat and Debian, so waste no time.

---

Pedro Bueno (pbueno /%%/ isc. sans. org)
Twitter: http://twitter.com/besecure

(c) SANS Internet Storm Center. https://isc.sans.edu Creative Commons Attribution-Noncommercial 3.0 United States License.
 
Initial Tasks under IDIQ Contract Total $29 Million to Operate Newly Established Federally Funded Research and Development CenterThe U.S. Commerce Departments National Institute of Standards and Technology (NIST) has awarded a contract ...
 
Xen 'x86_emulate.c' Local Privilege Escalation Vulnerability
 
Xen Supervisor Mode Permission Checks Local Denial of Service Vulnerability
 
Linux Kernel PicoLCD HID Device Driver Buffer Overflow Vulnerability
 
LinuxSecurity.com: An updated haproxy package that fixes one security issue is now available for Red Hat Enterprise Linux 7. Red Hat Product Security has rated this update as having Moderate security [More...]
 
LinuxSecurity.com: Several security issues were fixed in the kernel.
 
LinuxSecurity.com: Several security issues were fixed in the kernel.
 
LinuxSecurity.com: Several security issues were fixed in the kernel.
 
LinuxSecurity.com: Several security issues were fixed in the kernel.
 
LinuxSecurity.com: Several security issues were fixed in the kernel.
 
LinuxSecurity.com: Several security issues were fixed in the kernel.
 
LinuxSecurity.com: APT could be made to crash or run programs if it received specially craftednetwork traffic.
 
LinuxSecurity.com: Security Report Summary
 
LibVNCServer CVE-2014-6052 Denial of Service Vulnerability
 
[SECURITY] [DSA 3031-1] apt security update
 
Xen 'HVMOP_track_dirty_vram()' Local Denial of Service Vulnerability
 
CVE-2014-6603 suricata 2.0.3 Out-of-bounds access in SSH parser
 
[KIS-2014-10] X2Engine <= 4.1.7 (FileUploadsFilter.php) Unrestricted File Upload Vulnerability
 
[KIS-2014-09] X2Engine <= 4.1.7 (SiteController.php) PHP Object Injection Vulnerability
 
Linux Kernel 'ISOFS' Deadlock Local Denial of Service Vulnerability
 
Linux Kernel KVM 'virt/kvm/iommu.c' Denial of Service Vulnerability
 
Internet Storm Center Infocon Status